Frost bugs

View previous topic View next topic Go down

Frost bugs

Post by XpT_Nakamura on Thu Jun 14, 2012 12:17 pm

Frost is not working on set animals.
In the files, i did manage to fix this for the trainable set animals, not for the converted ones however.
Would it be acceptable if frost worked on "mother nature" animals?
Then again, i see the trainable ones to be the main problem.

XpT_Nakamura
Admin

Posts: 471
Join date: 2012-05-21
Age: 20
Location: U.K

View user profile http://aom-fp.forumotion.com

Back to top Go down

Re: Frost bugs

Post by [Hail]BoIt on Thu Jun 14, 2012 11:28 pm

Frost also bugs up bronze.
If you frost bronze then the units who were bronzed will have 99% armour.
If you cast bronze during frost then the units won't be effected by bronze when frost finishes.

I see no problem in frost effecting gaia animals. People shouldn't be hunting that close to a fight anyways... Razz

[Hail]BoIt

Posts: 147
Join date: 2012-05-23

View user profile

Back to top Go down

Re: Frost bugs

Post by XpT_Nakamura on Fri Jun 15, 2012 12:07 am

Dunno if i can fix the bronze frost bugs.
The error is within the basic coding, which i have no idea about.

XpT_Nakamura
Admin

Posts: 471
Join date: 2012-05-21
Age: 20
Location: U.K

View user profile http://aom-fp.forumotion.com

Back to top Go down

Re: Frost bugs

Post by [Hail]BoIt on Fri Jun 15, 2012 4:17 am

The error is in basic algebra and a condition or two.

Armour can't be above 99%
Frost increases Armour to 99%
Bronze increases armour by lets say 20% (dunno exact figures) but can't go above 99% :O
So armour stays at 99%
Frost then minuses the amount that it added meaning that bronze doesn't work Sad

Sorta vicaversa for other way round Razz

[Hail]BoIt

Posts: 147
Join date: 2012-05-23

View user profile

Back to top Go down

Re: Frost bugs

Post by XpT_Nakamura on Fri Jun 15, 2012 4:23 am

Frost changes the armor to 99% while it's active.
The problem is that somehow the armor values return to the initial armor (the active armor on casting of frost).
I don't know where to fix it.

XpT_Nakamura
Admin

Posts: 471
Join date: 2012-05-21
Age: 20
Location: U.K

View user profile http://aom-fp.forumotion.com

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

Permissions in this forum:
You cannot reply to topics in this forum